Осторожнее надо быть с обновлениями

May 25th, 2009 Begemot Posted in Использование

Выпустил новую версию менеджера буфера обмена, за день до релиза, в тестовых целях (проверить как работает скроллинг на дереве) обновился до wxWidgets 2.8.10. Задумался с какой версией собирать публичный релиз, старой “проверенной” 2.8.9 или новой .10 в которой много чего, по идее исправлено и улучшено, но сам то я не тестировал. Решил не рисковать, потом подумал, а фигли там, полюбому 2.8.10 должна быть лучше.

Уже в последний момент, собрав инталляшку, заметил багу. В 2.8.10 сломали html у меня пополз абаут и нагскрин. Пропачил wxWidgets, собрал заново – ошибка исчезла, но осадочек остался. Теперь ни каких больших обновлений third-party перед релизом, только заранее и тестировать, тестировать, тестировать…


Если пост полезен для вас вы можете подписаться на RSS или мы можем доставлять вам новые посты прямо в ваш почтовый ящик.

Related:

One Response to “Осторожнее надо быть с обновлениями”

  1. Однако напугал. Я тоже обновился до .10, и отчеты в HTML, пойду устрою стресс-тест